Back to overview
Degraded

Loading documents is currently very slow.

Sep 25, 2024 at 10:09am UTC
Affected services
Prostream

Resolved
Sep 25, 2024 at 10:13am UTC

We have resolved the issue and are monitoring performance.

Created
Sep 25, 2024 at 10:09am UTC

Loading documents is currently very slow. We are investigating the issue.