Back to overview
Degraded
Snagstream app does not work on iOS 17
Sep 19 at 09:00am CEST
Affected services
Snagstream
Resolved
Sep 20 at 10:00am CEST
We have updated the Snagstream app to be compatible with iOS 17. The update is available in the Apple Store.
Affected services
Snagstream
Created
Sep 19 at 09:00am CEST
We are experiencing issues with the Snagstream app on iOS 17. We are investigating the issue.
Affected services
Snagstream